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1. Purpose 
This manual is a step-by-step guide to building a Peplink FusionHub server. 

2. FusionHub License Generation 
 
If you already have set up an InControl 2 account, please skip to step 5 
 
1. To obtain FusionHub evaluation license information and download the FusionHub ISO 

file from InControl 2, first sign in. 
 

 
 

To sign in with Gmail, click Sign in with Google, choose your account, and then 
grant InControl 2 permissions. 

  

 
 

To sign in without Gmail, click Login and enter your information. Next, click the link 
found in your confirmation email. Return to the first screen to enter your username 
and password. 
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2. Once you successfully login, InControl 2 will prompt you to name your organization 
and choose your language. 

 

 
 
3. Name your group, choose a local time zone, and specify your location. Click Create 

group to finish.  
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4. On the Add devices into groups dialog, click Cancel to skip this step and create the 
group. 

 

 
 
5. To obtain an evaluation license, navigate to Organization>Settings>Warranty & 

License.  
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6. On the “Warranty Status” screen, click the Create Evaluation License button. 
 

 
 
  

To download the FusionHub, click the Download Latest FusionHub button located 
below the Create Evaluation License button.  
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7. InControl 2 will send the license information to the email address used to login. Follow 
the steps in the email to add a virtual router using your FusionHub serial number. 
 

8. To add FusionHub onto your organization, navigate to Organization>Settings>Add 
Devices.  
 

 
  



 

© 2016 Peplink  Page 7 

FusionHub Installation Guide 

 
9. Enter the serial number from your license information email. Click Add devices and 

continue your FusionHub installation. 
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3. FusionHub Download 
For all VM platforms besides Amazon Web Services, please download FusionHub from the 
following link:  
 
http://download.peplink.com/firmware/fusionhub/get 
 
For Amazon Web Services, please refer to page 62 for instructions on how to download 
and install.  

4. FusionHub Deployment 
This section will show how to implement FusionHub on VMware (ESXi server, Workstation, 
Player), Oracle VirtualBox, Citrix XenCenter, Microsoft Hyper-V, and Amazon Web Services. 
Please select your VM platform: 
 

4.1 VMware ESXi Server ............................................................................................ 8 
4.2 VMware Workstation ......................................................................................... 24 
4.3 VMware Player .................................................................................................. 32 
4.4 Oracle VirtualBox .............................................................................................. 42 
4.5 Citrix XenServer ................................................................................................ 47 
4.6 Microsoft Hyper-V ............................................................................................. 54 
4.7 Amazon Web Services ....................................................................................... 62 

 

4.1 VMware ESXi Server 

1. Download VMware ESXi 5.5.0 from www.vmware.com/go/download-vsphere 
and install it. 

 
2. For VMware vSphere server installation hardware requirements, refer to 

http://www.vmware.com/products/vsphere-
hypervisor/gettingstarted.html 

 
3. Open VMware vSphere. Enter the appropriate IP address / Name, User name, 

and Password. Click Login to login to the ESXi server. Make sure that your 
computer and ESXi server are on the same network. If your computer and ESXi 
server are not on the same network, you won’t be able to connect to FusionHub’s Web 
admin interface, even though you can remotely access the ESXi server through a 
router. Follow the steps found in 4 FusionHub Interface Configuration to connect 
to FusionHub’s Web admin interface. 

  

http://download.peplink.com/firmware/fusionhub/get
http://www.vmware.com/go/download-vsphere
http://www.vmware.com/go/download-vsphere
http://www.vmware.com/products/vsphere-hypervisor/gettingstarted.html
http://www.vmware.com/products/vsphere-hypervisor/gettingstarted.html
http://www.vmware.com/products/vsphere-hypervisor/gettingstarted.html
http://www.vmware.com/products/vsphere-hypervisor/gettingstarted.html
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4. After successfully logging in, click Inventory. The remaining contents of this section 
will cover deploying a FusionHub virtual machine to your ESXi server. 

 

 
 
5. Click the inventory object to begin deploying the OVF template. 
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6. Click File > Deploy OVF Template... to deploy the FusionHub OVF template 
downloaded from InControl 2. In order to deploy the OVF template successfully, please 
make sure that your ESXi server supports virtual machine version 8, which runs on 
VMware ESXi 5.5 and later. 

 

 
   
 
 
 
 
7. On the Source dialog of the Deploy OVF Template wizard, click Browse. Locate 

the FusionHub.ova template file on your computer and click Next. 
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8. On the Name and Location dialog, type a name or keep the default setting. Click 
Next. 
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9. Keep the default settings on the Disk Format dialog. Click Next. 
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10. On the Ready to Complete dialog, review the deployment settings. Click Finish to 
complete the process and close the wizard. 

 

  
  
11. Once you have completed the steps above, a FusionHub virtual machine is created. 
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12. Click FusionHub in the column on the left side of the dialog to select the virtual 
machine. Click Edit virtual machine settings to begin adding an Ethernet adapter to 
the FusionHub virtual machine. 
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13. Click Add, found under the Hardware tab on the FusionHub – Virtual Machine 
Properties dialog. 
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14. On the Add Hardware dialog, select Ethernet Adapter. Click Next. 
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15. On the Network Type dialog, select VMXNET 3 as the Adapter Type. Select the 
appropriate network and port settings from the drop-down menus under Network 
Connection. 

16. Check Connect at power on to connect the NIC when the virtual machine is powered 
on. 

17. Click Next. 
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18. On the Ready to Complete dialog, review your settings and click Finish. 
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19. Click OK to finish adding hardware. 
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20. Click Power on the virtual machine to run FusionHub. 
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21. When the FusionHub virtual machine is powered on, right-click FusionHub. Select 
Open Console for general information about FusionHub, including: 

 
● FusionHub version 
● System information 
● Network settings: 

Method: DHCP 
IP Address: None 
Admin: http://169.254.254.254 
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22. The default WAN connection method is DHCP. If the DHCP server is available on your 

network, the FusionHub IP address will be automatically obtained by the DHCP server. 
In this case, the console will look similar to the following: 

 

 
  
Please navigate to FusionHub Interface Configuration to continue your installation.
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4.2 VMware Workstation 

1. Click FusionHub in the column on the left side of the dialog to select the virtual 
machine. Click Edit virtual machine settings to begin adding an Ethernet adapter to 
the FusionHub virtual machine. 

2. Download VMware Workstation 10 from 
http://www.vmware.com/products/workstation/ and install it. For VMware 
Workstation installation hardware requirements, refer to 
http://pubs.vmware.com/workstation-
10/index.jsp?topic=%2Fcom.vmware.ws.using.doc%2FGUID-55FF3F07-6C2E-41F7-
B361-C7D870BCC4D7.html 

3. Open VMware Workstation and deploy the OVF template. 
4. Click File > Open to open the FusionHub.ova template downloaded from InControl 2. 
 

 
  
 
  

http://www.vmware.com/products/workstation/
http://pubs.vmware.com/workstation-10/index.jsp?topic=%2Fcom.vmware.ws.using.doc%2FGUID-55FF3F07-6C2E-41F7-B361-C7D870BCC4D7.html
http://pubs.vmware.com/workstation-10/index.jsp?topic=%2Fcom.vmware.ws.using.doc%2FGUID-55FF3F07-6C2E-41F7-B361-C7D870BCC4D7.html
http://pubs.vmware.com/workstation-10/index.jsp?topic=%2Fcom.vmware.ws.using.doc%2FGUID-55FF3F07-6C2E-41F7-B361-C7D870BCC4D7.html
http://pubs.vmware.com/workstation-10/index.jsp?topic=%2Fcom.vmware.ws.using.doc%2FGUID-55FF3F07-6C2E-41F7-B361-C7D870BCC4D7.html
http://pubs.vmware.com/workstation-10/index.jsp?topic=%2Fcom.vmware.ws.using.doc%2FGUID-55FF3F07-6C2E-41F7-B361-C7D870BCC4D7.html
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5. On the Store the new Virtual Machine dialog, type a name for the new virtual machine 
(i.e., FusionHub) and select the storage path. Please note that the storage path for this 
FusionHub virtual machine should not be the same as for the downloaded FusionHub 
OVF template file. Click Import. 

 

 
 
6. After successful import, a FusionHub virtual machine is created. 
 

 
 

7. Click FusionHub in the column on the left side of the dialog to select the virtual 
machine. Click Edit virtual machine settings to begin adding an Ethernet adapter. 

 

  
 
  



 

© 2016 Peplink  Page 26 

FusionHub  Guide – Installation on VMware ESXi Server FusionHub Installation Guide – Installation on VMware ESXi Server 

8. Click Add, found under the Hardware tab on the Virtual Machine Settings dialog. 
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9. On the Add Hardware Wizard dialog, select Network Adapter. Click Next. 
 

 
  
10. On the Network Adapter Type dialog, select Bridged: Connected directly to the physical 

network and Replicate physical network connection state. Check Connect at power on 
and click Finish. 

 

  
 
 
 
11. Click Configure Adapters to select the host adapter. This will apply only if you have 

more than one network adapter. Otherwise, skip this step. 
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12. When the Automatic Bridging Settings dialog opens, select the host network 

adapter you want to automatically bridge and click OK. 
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13. Click OK to finish adding hardware. 
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14. Click Power on this virtual machine to run FusionHub. 
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15. The FusionHub console opens automatically and displays the following general 
information about FusionHub: 

 
● FusionHub version 
● System information 
● Network settings: 

Method: DHCP 
IP Address: None 
Admin: http://169.254.254.254 
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16. The default WAN connection method is DHCP. If the DHCP server is available on your 
network, the IP address of FusionHub will be automatically obtained by DHCP server. 
In this case, the console will look similar to the following: 

  

 
  
 
Please navigate to FusionHub Interface Configuration to continue your installation.
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4.3 VMware Player 

1. Download VMware Player 6.0 from 
https://my.vmware.com/web/vmware/free#desktop_end_user_computing
/vmware_player/6_0 and install it. 

2. Open VMware Player and install FusionHub. 
3. Click Open a Virtual Machine to import the FusionHub.ova template downloaded 

from InControl 2. 
 

 
  
 
  
 
  

https://my.vmware.com/web/vmware/free#desktop_end_user_computing/vmware_player/6_0
https://my.vmware.com/web/vmware/free#desktop_end_user_computing/vmware_player/6_0
https://my.vmware.com/web/vmware/free#desktop_end_user_computing/vmware_player/6_0
https://my.vmware.com/web/vmware/free#desktop_end_user_computing/vmware_player/6_0
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4. On the Store the new Virtual Machine dialog, type a name for the new virtual machine 
(i.e., FusionHub) and select the storage path. Please note that the storage path for this 
FusionHub virtual machine should not be the same as that for the downloaded 
FusionHub OVF template file. Click Import. 

 

 
 
5. After successful import, a FusionHub virtual machine is created. 
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6. Click FusionHub in the column on the left side of the dialog to select the virtual 
machine. Click Edit virtual machine settings to begin adding an Ethernet adapter to 
the FusionHub virtual machine. 
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7. Click Add, found under the Hardware tab on the Virtual Machine Settings dialog. 
 

  
 
  
 
  



 

© 2016 Peplink  Page 37 

FusionHub  Guide – Installation on VMware ESXi Server FusionHub Installation Guide – Installation on VMware ESXi Server 

8. On the Add Hardware Wizard dialog, select Network Adapter. Click Next. 
 

  
 
9. On the Network Adapter Type dialog, select Bridged: Connected directly to the physical 

network and Replicate physical network connection state. Check Connect at power on 
and click Finish. 

 

 
 
 
10. Click Configure Adapters to select the host network adapter. 
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11. On the Automatic Bridging Settings dialog, select the host network which you want 

to automatically bridge. Click OK to finish adding hardware. 
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12. Click Play virtual machine to run FusionHub.  
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13. The FusionHub console opens automatically and displays the following general 
information about FusionHub: 

 
● FusionHub version 
● System information 
● Network settings: 

Method: DHCP 
IP Address: None 
Admin: http://169.254.254.254 
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14. The default WAN connection method is DHCP. If the DHCP server is available on your 
network, the FusionHub IP address will be automatically obtained by the DHCP server. 
In this case, the console looks similar to the following: 

  

  
 
Please navigate to FusionHub Interface Configuration to continue your installation.
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4.4 Oracle VirtualBox 

1. Download VirtualBox from https://www.virtualbox.org/wiki/Downloads and 
install it. 

2. Open VirtualBox. Click New to create a virtual machine for FusionHub. 
 

 
 
  

https://www.virtualbox.org/wiki/Downloads
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3. On the Create Virtual Machine dialog, specify a Name for the virtual machine. 
Select Linux from the Type drop-down menu. Select Other Linux (64-bit) from the 
Version drop-down menu. Click Next to continue. 

 

 
 
4. Set the memory size to 1024MB. Click Next. 
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5. Click Use an existing virtual hard drive file. Select the fusionhub.vmdk file 
downloaded from InControl 2. Click Create to create a virtual machine. 
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6. Select the newly created FusionHub VM and click Settings. 

 
 
7. On the FusionHub - Settings dialog, click Network. Select the Adapter 1 tab. Click 

Enable Network Adapter and select Bridged Adapter from the Attached to: 
drop-down menu. Select a proper adapter from the Name drop-down menu. Click OK 
to continue. 
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8. Select the FusionHub VM. Click Start to run FusionHub. 
 

 
 
 
Please navigate to FusionHub Interface Configuration to continue your installation.
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4.5 Citrix XenServer 

1. Download and install the XenCenter installer from your XenCenter server. 
 

 
 
2.  Open XenCenter. Click ADD a server.  
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3. On the Add New Server dialog, enter the appropriate Server IP address/name, User 
name, and Password. Click Add to add the XenServer. 
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4. Enable E1000 gigabit device emulation in Citrix XenServer to take advantage of 
FusionHub’s support for E1000 gigabit devices. For details, please refer to: 
http://www.netservers.co.uk/articles/open-source-howtos/citrix_e1000_gigabit 
 

5. Right-click the XenServer and select Import to begin importing the OVA file to this 
XenServer. 

 

 
 
  

http://www.netservers.co.uk/articles/open-source-howtos/citrix_e1000_gigabit
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6. On the Import dialog, select the FusionHub.ova file downloaded from InControl 2. 
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7. Click Next to keep the default settings and display the Configure networking 
options for the Transfer VM dialog. Select an appropriate network on which the 
temporary VM used to perform the import operation will run. Click Next. Click Finish 
to import the OVF file. 

 

  
 
 
8. Click FusionHub -> Networking -> Add Interface to add a network interface. 
 

 
 
8. Click FusionHub -> Networking -> Add Interface to add a network interface.  
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9. On the Add Virtual Interface dialog, select the network and click Add. 
 

 
 
10. Click FusionHub -> Start to run this FusionHub virtual machine. 
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11. Click FusionHub -> Console to open the console. 
 

 
 
Please navigate to FusionHub Interface Configuration to continue your installation.
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4.6 Microsoft Hyper-V 

 
1. Open Hyper-V and install FusionHub, click New -> Virtual Machine to create a virtual 
machine for FusionHub. 
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2. On the Specify Name and Location dialog, specify a name for the virtual machine. 
Click Next. 
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3. On the Specify Generation dialog, choose Generation 1. Click Next. 
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4. On the Assign Memory dialog, set the memory size to 1024MB. Click Next. 
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5. On the Configure Networking dialog, select a network adapter and click Next 
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6. On the Connect Virtual Hard Disk dialog, select “Use an existing virtual hard 
disk” and select FusionHub.vhd from the location you downloaded FusionHub. Click Next. 
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7. Click Finish to complete virtual machine configuration. 
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8. Click Start to to run this FusionHub virtual machine. 
 

 
 
 
Please navigate to FusionHub Interface Configuration to continue your installation.
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4.7 Amazon Web Services 

 
Acquiring FusionHub for AWS 
 

1. Currently, the only means to acquiring FusionHub for AWS is through private 
sharing. You would need to provide the following information to trial@peplink.com. 
Peplink will then share the AMI image to your account: 

 

 InControl2 account username 

 Amazon EC2 region (e.g. Oregon) 

 12-digit Amazon ID 
 

2. Login to your AWS Management Console 

3. In the left hand panel, expand “Images”, select “AMIs”. 

4. At the top, locate “Filter:” and pick “Private images”. 

5. Click on “Peplink FusionHub” to highlight it. A blue dot will appear to show that it is 
currently highlighted. 

6. Click on the “Launch” button at the top. 
 

 

 
Setting the Instance type 
 

1. In the next screen “Choose an Instance Type, click to highlight “t2.micro” 

2. Then click “Configure Instance Details” at the bottom right of the page. 
  

mailto:trial@peplink.com?subject=Open%20beta:%20FusionHub%20for%20Amazon%20Web%20Services
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Configuring the Instance 
 

1. The “Configure Instance Details” page allows you to make changes to the Instance 
details and network interfaces. If you’re unsure what these should be, then please 
skip this step. 
 

2. Click “Review and Launch” at the bottom right 
 



 

© 2016 Peplink  Page 64 

FusionHub Installation Guide – Installation on Amazon Web Services 

 
 

 
 

3. In the next page “Review Instance Launch”, click on “Edit security groups”. 
 

 
 

4. Configure the security group settings as follows: 
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 Remove SSH 

 Add TCP 2222/32015 

 Add UDP 4500 

 Add HTTP/HTTPS 
 

5. Click “Review and Launch” 
 

 
6. Confirm that the details are correct, and then click “Launch”. 

 

 
Tweak the running Instance 
 

1. In the left hand panel, expand “Instances” and click on “Instances”. 
 

2. Select FusionHub’s running instance by clicking on it once. 
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3. After highlighting the running instance, right-click to bring up the context menu. 
 

4. Click on “Change Source/Des. Check” in the context menu 
 

5. Select “Disable Source/Dest. Check”. 
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Accessing FusionHub 
 

1. Note down FusionHub’s public IP address. 

 
 

2. In your web browser, type in “http://[FusionHub.instance.public.ip.address]” in 
order to access FusionHub’s administration interface. In our example, the line to 
type into the web browser would be: http://54.213.85.2/ 
 

3. Follow Section 5 to continue. 

http://54.213.85.2/


 

© 2016 Peplink  Page 69 

FusionHub Installation Guide 

5. FusionHub Interface Configuration 

5.1 Connecting to FusionHub’s Web Admin Interface 

1. Open a Web browser on the computer hosting your Peplink FusionHub virtual machine. 
 
2. To access FusionHub’s Web admin interface, connect your computer to the network on 

which FusionHub is running. The default WAN connection method for FusionHub is 
DHCP. 

 
3. If the DHCP server is available in your network, the FusionHub IP address will be 

automatically obtained by the DHCP server. The Web admin address will appear on the 
FusionHub console automatically (i.e., Admin: http://10.8.8.252). Enter the Web admin 
address (i.e., http://10.8.8.252) in your Web browser's address field. 

 
4.  If there is no DHCP server in your network, set your computer’s IP address to 

169.254.x.x (x denotes any integer from 2 to 253), using a subnet mask of 
255.255.0.0. 

 
5. After successfully changing these settings, enter http://169.254.254.254 in your 

Web browser’s address field. 
 
6. Next, access the Web admin interface by entering admin for both the user name and 

password. The default admin and read-only user passwords can be changed after 
logging into the Web admin interface at System > Admin Security. 
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7. Once you have successfully logged in, the Setup Wizard will be displayed. 
 

 

5.2 Configuration Using the Setup Wizard 

FusionHub’s Setup Wizard leads you step-by-step through the process of configuring 
your WAN connection. 
 
1. Click Setup Wizard after connecting to the Web admin interface.  

 
 
2. Click Next to begin. 
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3. Click Next to configure the WAN connection. Select the WAN connection method from 
the following screen. The default selection is DHCP. 

 

 
  
4. Depending on the selected connection type, further configuration may be needed: 
 
•   If Static is selected, the Setup Wizard will display Static IP Settings. 
 

   
•   If DHCP is selected, the Setup Wizard will display DHCP Settings. 
 

 
 
 
 
 
 
 
 
 
 



 

© 2016 Peplink  Page 72 

FusionHub Installation Guide 

 
 
•   If PPPoE is selected, the Setup Wizard will display PPPoE Settings. 
 

 
During this step, make sure the FusionHub and ESXi servers are on the same network if 
Static is selected. For example: 
  
If the ESXi server’s IP settings are: 
IP address: 10.8.9.124 
Subnet mask: 255.255.0.0 
Default gateway: 10.8.8.1 
  
Configure port settings as follows: 
IP address: 10.8.x.x (x denotes any integer from 2 to 254) 
Subnet mask: 255.255.0.0 
Default gateway: 10.8.8.1 
  

 
 
5. If there is more than one port on the ESXi server and you have assigned two network 

adapters to this FusionHub virtual machine, the LAN port configuration dialog will be 
open. The default selection is Static. 
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● If Static is selected, the Setup Wizard will display Static IP Settings. 
 

 
 

● If DHCP is selected, the Setup Wizard will display DHCP Settings. 
 

 
 

● If Disable is selected, the Setup Wizard will move to the next step. 
 
Note: FusionHub virtual machines support a maximum number of two network adapters. 
By default, Network adapter 1 is set as the WAN port, and Network adapter 2 is set 
as the LAN port. 
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6. Click Next to define a Local ID before using PepVPN. The local ID is a text string that 

identifies this local unit when establishing a VPN connection. Remote units can identify 
this unit using the local ID, as well as by serial number. When creating a profile on a 
remote unit, this unit’s local ID must be entered into the remote unit’s Remote ID 
field. 

 

 
 
7. Click Next to choose the time zone of your country/region. Check Show all to       

display all time zone options. 

  

 
 
8. Check to make sure all settings have been configured correctly, and then click Save 

and Apply Settings to confirm. 
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9. You will be redirected to the License Information dialog. The default selection for 

Virtual Machine Model is VMware ESXi. The default License Information dialog 
looks similar to the following:  

 

  
 
If you are not using VMware ESXi, please select Other for the Virtual Machine \Model. 
In that case, the license activation dialog will look similar to this: 
 

 
 

● License Key is the FusionHub license key obtained from the InControl2 
webpage. Please refer to FusionHub License Generation for details on creating 
this license key. 

● Virtual Machine Model is the virtual machine platform on which FusionHub 
is implemented. If FusionHub is implemented on a VMware ESXi Server, please 
select VMware ESXi. If it is implemented on a VMware Workstation or VMware 
Player, please select Other. 

● ESXi Server address is the ESXi server's hostname or IP address. Note: 
this column is shown only when VMware ESXi is selected. 

● Click Submit after filling the form. 
  
 
 
 
 
 
 
 
 
 
 
 
10. When the license is successfully activated, you will see the following screen: 
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 The information shown on the FusionHub console will change to the following: 
 

  
 
If you have changed your computer’s IP to 169.254.x.x, please change the computer’s IP 
settings so that they’re the same as your FusionHub network settings, and then connect to 
FusionHub’s Web admin again. 
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6. PepVPN with SpeedFusion Settings 
This section will describe how to set up PepVPN with SpeedFusion. 

6.1  Background 

Peplink FusionHub securely connects one or more branch offices to your company's main 
datacenter or to other branches. Data, voice, and video communications between these 
locations are kept confidential across the public Internet. 
 
FusionHub’s SpeedFusion Bandwidth Bonding feature, enabled by default, is specifically 
designed for multi-WAN environments. FusionHub can bond all WAN bandwidth for routing 
SpeedFusion traffic, and unless all of one site’s WAN connections are down, the Peplink 
Balance can keep your VPN up and running. 
 
When supporting multiple VPN connections, FusionHub can act as a central hub that 
connects branch offices. For example, if Branch Office A and Branch Office B make VPN 
connections to Headquarters C, both branch office LAN subnets and the subnets behind 
them (e.g., static routes) will also be advertised to Headquarters C and the other 
branches. In this example, Branch Office A will be able to access Branch Office B via 
Headquarters C. 
 
The local LAN subnet and subnets behind the LAN will be advertised to the VPN. All VPN 
members (branch offices and the datacenter) will be able to route to local subnets. 
Note that all LAN subnets and subnets behind them must be unique. Otherwise, VPN 
members will not be able to access each other. 
 
All data can be routed over the VPN using the 256-bit AES encryption standard. 
In the following sections, three FusionHub application examples illustrate how to set up 
your devices. 
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6.2  Example One 

 
Figure 5.1 Remote Access to Central Server 
 
To set up the scenario shown in Figure 5.1, we need to configure a MAX HD2 at Site A, a 
MAX BR1 at Site B, and FusionHub (two network adapters are needed) at the Datacenter. 
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In our case, FusionHub settings (refer to Configuration Using the Setup Wizard) are 
as follows: 
 
IP address: 10.8.50.50 (static IP) 
Netmask: 255.255.0.0 
Default gateway: 10.8.8.1 
Local ID: FusionHubVM 
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MAX HD2 LTE configuration (Site A) 
Suppose that the MAX HD2 in Figure 5.1 is configured with the following IP settings: 
 
WAN 1 IP address: 10.10.13.49 
WAN 2 IP address: 10.10.13.50 
LAN IP address: 192.168.150.1 
 
1. To configure, connect to the Web admin interface of the MAX HD2, and then navigate 

to Advanced > SpeedFusion. 
  

 
 

2. Next, click  under PepVPN. 
 

 
 
3. Enter a Local ID, such as MAX-HD2, for this MAX HD2, and then click OK. 
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4. Click New Profile under Profile to add a new profile. 
 

 
 
5. On the dialog displayed next, fill the form as follows: 
 
Name – Enter a name to represent this profile. In this case, we chose FusionHub. 
 
Remote ID – Remote ID should be the same as FusionHub's Local ID. In our case, the 
FusionHub local ID is FusionHubVM. 
 
Click Preshared Key and create a pre-shared key, which is 12345678 in our example. 
 
Remote IP addresses – Here, we’ve entered 10.8.50.50, the FusionHub IP address. 
 

 
 
6. After completing the form, click Save and then Apply Changes. 
 
MAX BR1 configuration (Site B) 
Assume the MAX BR1’s IP settings are: 
 
WAN IP address: 10.9.3.167 
LAN IP address: 192.168.71.1 
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1. To configure the MAX BR1, connect to the MAX BR1’s Web admin interface (in our 

case, the Web admin interface address is http://192.168.71.1), and then navigate 
to Advanced >PepVPN. 

 

 
 

2. Click   under PepVPN. 
 

 
 
3. Enter a Local ID, such as MAX_BR1_169B, for this MAX BR1, and then click OK. 
 

  
 



 

© 2016 Peplink  Page 83 

FusionHub Installation Guide 

4. Click New Profile under Profile to add a new profile. 
 

 
 
5. On the dialog displayed next, fill the form as follows: 
 
Name – Enter a name to represent this profile. In this case, we chose FusionHub. 
 
Remote ID – Remote ID should be the same as FusionHub's Local ID. In our case, the 
FusionHub local ID is FusionHubVM. 
 
Click Preshared Key and create a pre-shared key, which is 23456789 in our example. 
 
Remote IP addresses – Here, we’ve entered 10.8.50.50, the FusionHub IP address. 
 

 
 
6. After completing the form, click Save and then Apply Changes. 
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C. FusionHub configuration (Datacenter) 
In our example, the IP address of the ESXi server is 10.8.9.24/16, and the FusionHub IP 
address is 10.8.50.50/16. 
 
1. To configure FusionHub, connect to the FusionHub Web admin interface 

(http://10.8.50.50) again. Then, navigate to Network > SpeedFusion. 
 

 
 
2. To add a new profile, click the New Profile button. On the dialog displayed next, fill 

the form as follows: 
 
Name – Enter a name to represent this profile. In this case, since we’re adding the MAX 
HD2 to Site A, we chose Site A. 
 
Remote ID – Remote ID should be the same as the MAX HD2's Local ID. In our case, 
the MAX HD2’s local ID is MAX-HD2. 
 
Click Preshared Key, and then enter the same pre-shared key used with the MAX 
HD2, 12345678 in our example. 
 

 
 
3. After completing the form, click Save and then Apply Changes. 
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4. Click New Profile again to add the MAX BR1 to Site B. 
 
Name – Enter a name to represent this profile. In this case, since we’re adding the MAX 
BR1 to Site B, we chose Site B. 
 
Remote ID – Remote ID should be the same as the MAX BR1's Local ID. In our case, 
the local ID is MAX-BR1-169B. 
 
Click Preshared Key and enter the same pre-shared key used with the MAX BR1, 
23456789 in our example. 
 
5. After completing the form, click Save and then Apply Changes. 
 

 
 
6. On the Dashboard, we see that PepVPN with SpeedFusion has been established for 

Site A and B. 
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7. In order to make a direct link between FusionHub and the video server shown on the 
right-hand side of Figure 5.1, we need to add one more port (a network adapter) to 
FusionHub’s virtual machine. 

 
Adding a network adapter when using ESXi server 

a. Login to the ESXi server again, and then power off the FusionHub virtual machine. 
Next, click Edit virtual machine settings. On the FusionHub – Virtual 
Machine Properties dialog, click Add to add another network adapter. 
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b. Select Ethernet Adapter, and then click Next. 
 

 
 

c. Select a network and adapter from the drop-down menus, and then click Next. 
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d. Click Finish and then OK to save your settings. 
 

 
 
Adding a network adapter when using VMware Workstation 
 

a. Power off the FusionHub virtual machine and select Edit > Virtual Network 
Editor 
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b. Under VMnet Information, select VMnet0 and check Bridged (connect VMs 
directly to the external network). Select the appropriate network adapter from 
the drop-down menu and click OK. 
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c. Click Add Network. 
 

 
 

d. On the Add a Virtual Network dialog, select a network to add from the drop-
down menu and click OK. In this example, we selected VMnet2. 
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e. Select the VMnet2 network added in the previous step and check Bridged 
(connect VMs directly to the external network). Click OK to apply changes. 
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f. Click FusionHub and select Edit virtual machine settings. On the Virtual Machine 
Settings dialog, select Network adapter. Check Custom: Specific virtual network and 
select VMnet0 (Bridged). Then click Add to add another network adapter. 
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g. Select Network Adapter and click Next. 
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h. Check Custom: Specific virtual network and select VMnet2 (Bridged) from 
the drop-down menu. Click Finish to complete the network adapter addition 
process. 

 

 
 
 
Adding a network adapter when using VMware Player 
The Virtual Network Editor is not available in VMware Player. If you want to test this 
example with VMware Player, first add a virtual network editor to VMware Player. Then 
follow the steps described in VMware Workstation to modify and add network adapters. 
For details on adding a virtual network editor to VMware Player, refer to 
http://www.eightforums.com/virtualization/5137-how-add-virtual-network-editor-vmware-
player-2.html#post275406 
 
8. After adding one or more network adapters to the FusionHub virtual machine, select 

FusionHub again. Click Power on the virtual machine, and then reconnect to the 
FusionHub Web admin interface. Navigate to Network > LAN. 

  

 
 
 
 
 

http://www.eightforums.com/virtualization/5137-how-add-virtual-network-editor-vmware-player-2.html#post275406
http://www.eightforums.com/virtualization/5137-how-add-virtual-network-editor-vmware-player-2.html#post275406
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9. Once you’ve set up the LAN port, click Save and then Apply Changes. In this case, 
the IP address of Port 2 is 172.16.31.100. 
 

 
 
10. To set up the video server as shown in Figure 5.1, enter 172.16.31.x as its IP 

address, and then set the default gateway so that it is the same as the IP address of 
FusionHub's port (in this example, the video server’s default gateway address is 
172.16.31.100). Finally, directly link the video server and FusionHub Port 2 with one 
network cable. 

 
 

 
Figure 5.1 Remote access to central server 
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6.3  Example Two 

 

 
Figure 5.2 Offices interconnect 
 
In this example, the hosts located at Office A want to communicate with the host located 
at Headquarters. 
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Case one: Supposing that network access is always made from Office A to Headquarters, 
setup your devices as follows: 
 
 MAX BR1 Settings 
The settings for the MAX BR1 in Office A are the same as those in the first example, 
except that the Remote IP Address/Host Names Optional item in the PepVPN profile 

for FusionHub should be changed to the IP address of the firewall/router . 
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FusionHub Settings 
The FusionHub settings are also the same as those used in the first example, except that 
we need only one FusionHub port in this example. Therefore, if you have added a second 
port during Example One, please complete the following steps to remove one port: 
 

1. Power off the FusionHub 
2. Remove the network adapter added in Example One 
3. Power on the FusionHub 

 
Next, connect to the FusionHub Web admin interface. Navigate to Network > WAN. 
Check the box under SpeedFusion Peers Access Internal Network to enable it. To 
save your changes, click OK and then Apply Changes. 
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Check NAT Mode in the PepVPN profile for FusionHub. 
 

 
 

Firewall/Router  settings 
Forward UDP port 4500 to FusionHub (192.168.200.12, in our example). Then forward 
TCP port 32015 to FusionHub (192.168.200.12, in our example). 
  
Case two: Supposing that network access needs to be available on both sides: 
Follow the same steps in case one except in Step 2 do not check NAT Mode in the 
PepVPN profile for FusionHub. 
 
Configuring the hosts located on the Headquarters LAN  
In Figure 5.2, the host located on the Headquarters LAN is a PC named Internal Server. 
In this example, you would need to add a static return route on this PC. For a PC running 
Windows, the command to add a static route is route add -p <MAX BR1 LAN's network> 
<MAX BR1's netmask> <FusionHub's local IP address>. 
 
Example: > route add -p 192.168.71.0 mask 255.255.255.0 192.168.200.12 (assuming 
FusionHub's local IP is 192.168.200.12). Here, -p makes the added route persistent across 
system reboots. This option is not supported in Windows 95. 
  
NOTE: If you use a Peplink product as your firewall/router in this example, you will need 
to disable all PepVPN with SpeedFusion profiles. 
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6.4  Example Three 

 
Figure 5.3 Public VPN Access / Location Dependent Content Access 
 
In this case, the settings of the MAX BR1 in Country A and the MAX HD2 in Country B are 
similar to those settings in the first example. However, the following changes must be 
made: 
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MAX BR1 Settings 

1. Navigate to Advanced > PepVPN, and then click  under Outbound Policy. 
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2. On the dialog displayed next, check the box under Send All Traffic To. Select 

FusionHub from the drop-down menu. Here, FusionHub is the profile name. Next, 
set DNS server to the same address used by FusionHub's DNS server, which is 
10.8.8.1 in this example. To save your changes, click OK and then Apply Changes. 

  

 
 
MAX HD2 Settings 

1. Navigate to Advanced > SpeedFusion, and then click  under Send All Traffic To.  
 

 
 
2. On the dialog displayed next, check the box under Send All Traffic To. Select 

FusionHub from the drop-down menu. Here, FusionHub is the profile name. Next, 
set DNS Server to the same address used by FusionHub's DNS server, which is 
10.8.8.1 in this example. To save your changes, click OK and then Apply Changes. 
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The FusionHub settings are also similar to those settings in the first example, except that 
we need only one FusionHub port in this example. Enabling SpeedFusion Peers Access 
Internal Network is not needed here, so we’ve left the box unchecked. 
  

 
 


